我爱环境保护-65环保网:提供绿色环保咨讯、一站式环保管家咨讯!
  • 首页
  • 财经知识
  • 通达信-自用变色MACD(含均线\RSI\KDJ共振)提示副图公式

通达信-自用变色MACD(含均线\RSI\KDJ共振)提示副图公式

发布:65环保2019-7-5 9:51分类: 财经知识 标签: 意见 原创 股票池 操作

2019-07-05_174720.png

神奇线:=EMA(C,13),COLORRED;

生命线:=EMA(C,55),COLORGREEN;

{RSI}

LC:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;

{KDJ}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

{MACD}

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORLIGREEN,LINETHICK1;

IF(DIFF>REF(DIFF,1),DIFF,DRAWNULL),COLORRED,LINETHICK1;

DEA:EMA(DIFF,9),COLORLIGREEN,LINETHICK1;

IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORRED,LINETHICK1;

MACD1:=2*(DIFF-DEA),LINETHICK2;

0,COLORLIGREEN,LINETHICK3;

IF(MACD1=0 OR MACD1>0,0,DRAWNULL),COLORRED,LINETHICK3;

{上涨共振标识}

{K 上穿 D}

FLAG1:=CROSS(K,D) AND REF(K,1)<K;

{DIFF 上穿 DEA }

FLAG2:=CROSS(DIFF,DEA) AND REF(DIFF,1)<DIFF;

{RSI1 上穿 RSI2}

FLAG3:=CROSS(RSI1,RSI2) AND REF(RSI1,1)<RSI1;

{KDJ 和 MACD 同时上穿}

FLAG11:=(FLAG1=1) AND (FLAG2=1);

{MACD 和 RSI 同时上穿}

FLAG12:=(FLAG3=1) AND (FLAG2=1);

{KDJ 和 RSI 同时上穿}

FLAG13:=(FLAG1=1) AND (FLAG3=1);

FLAG133:=(FLAG1=1)  AND (FLAG2=1) AND (FLAG3=1);

{DRAWICON(FLAG11 AND DIFF>REF(DIFF,1) AND DEA>REF(DEA,1),DEA,34);}

{DRAWICON(FLAG12 AND DIFF>REF(DIFF,1) AND DEA>REF(DEA,1),DEA,34);}

{DRAWICON(FLAG13 AND DIFF>REF(DIFF,1) AND DEA>REF(DEA,1),DEA,34);}

DRAWICON(FLAG133,DEA,1);

{下跌共振标识}

FLAG1_1:=REF(K,1)>D AND K<D AND REF(K,1)>K;

FLAG2_1:=REF(DIFF,1)>DEA AND DIFF<DEA AND REF(DIFF,1)>DIFF;

FLAG3_1:=REF(RSI1,1)>RSI2 AND RSI1<RSI2 AND REF(RSI1,1)>RSI1;

{FLAG111:=(FLAG1_1=1) AND (FLAG2_1=1);}

{FLAG121:=(FLAG2_1=1) AND (FLAG3_1=1);}

{FLAG131:=(FLAG1_1=1) AND (FLAG3_1=1);}

FLAG1333:=(FLAG1_1=1)  AND (FLAG2_1=1) AND (FLAG3_1=1);

{DRAWICON(FLAG111 AND DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,35);}

{DRAWICON(FLAG121 AND DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,35);}

{DRAWICON(FLAG131 AND DIFF<REF(DIFF,1) AND DEA<REF(DEA,1),DIFF,35);}

DRAWICON(FLAG1333,DIFF,2);

{MACD空中加油形态确定}

{DIFF与DEA接近值}

NN:=1.5;

{55日均线上做多}

MM:=55;

MACD空中加油1:=MACD1>=0 AND REF(MACD1,1)>=0 AND REF(MACD1,2)>=0 AND REF(MACD1,3)>=0;

MACD空中加油2:=MACD1>REF(MACD1,1);

MACD空中加油3:=REF(MACD1,1)<REF(MACD1,2);

MACD空中加油4:=REF(MACD1,2)<REF(MACD1,3);

MACD空中加油:=MACD空中加油1 AND MACD空中加油2 AND MACD空中加油3 AND MACD空中加油4 AND C>EXPMA(C,55) AND EXPMA(C,13)>EXPMA(C,55);

DRAWICON(MACD空中加油,DEA,1);

{自我提示}

DRAWTEXT_FIX(1=1,0.85,0.06,0,'希望和恐惧是人天性不能割除但要克制'),COLORRED;

DRAWTEXT_FIX(1=1,0.85,0.20,0,'股票永远不会因为价格太高而不可买进'),COLORRED;

DRAWTEXT_FIX(1=1,0.85,0.32,0,'严禁亏损加筹码顺从市场才能获取利润'),COLORRED;

已有 0/60 人参与

发表评论:

京东购物,支持网站请点击购买!
扫描二维码

扫描二维码关注本站,了解更新资讯!