我爱环境保护-65环保网:提供绿色环保咨讯、一站式环保管家咨讯!
  • 首页
  • 财经知识
  • 通达信-13\21\55日变色指数均线金叉及股票基本情况(ROE\换手率\流通比\)主图显示公式

通达信-13\21\55日变色指数均线金叉及股票基本情况(ROE\换手率\流通比\)主图显示公式

发布:65环保2019-7-5 9:47分类: 财经知识 标签: 意见 原创 股票池 操作

2019-07-05_174720.png

{指标均线}

EXPMA13:=EXPMA(C,13),COLORLIGREEN,LINETHICK1;

EXPMA21:EXPMA(C,21),COLORLIGREEN,LINETHICK2;

EXPMA55:EXPMA(C,55),COLORLIGREEN,LINETHICK2;

{IF(EXPMA13>REF(EXPMA13,1),EXPMA13,DRAWNULL),COLORRED,LINETHICK1;}

IF(EXPMA21>REF(EXPMA21,1),EXPMA21,DRAWNULL),COLORRED,LINETHICK2;

IF(EXPMA55>REF(EXPMA55,1),EXPMA55,DRAWNULL),COLORRED,LINETHICK2;

{一日穿}

FLAG11:=CROSS(EXPMA13,EXPMA21) AND CROSS(EXPMA13,EXPMA55) AND CROSS(EXPMA21,EXPMA55);

FLAG1:=FLAG11;

{二日穿}

FLAG21:=CROSS(REF(EXPMA13,1),REF(EXPMA21,1)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG22:=CROSS(REF(EXPMA13,1),REF(EXPMA21,1)) AND CROSS(EXPMA13,EXPMA55) AND CROSS(EXPMA21,EXPMA55);

FLAG23:=CROSS(REF(EXPMA13,2),REF(EXPMA21,2)) AND CROSS(EXPMA13,EXPMA55) AND CROSS(EXPMA21,EXPMA55);

FLAG24:=CROSS(REF(EXPMA13,2),REF(EXPMA21,2)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG2:=FLAG21 OR FLAG22 OR FLAG23 OR FLAG24;

{三日穿}

FLAG31:=CROSS(REF(EXPMA13,2),REF(EXPMA21,2)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG314:=CROSS(REF(EXPMA13,4),REF(EXPMA21,4)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG32:=CROSS(REF(EXPMA13,4),REF(EXPMA21,4)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG33:=CROSS(REF(EXPMA13,3),REF(EXPMA21,3)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG331:=CROSS(REF(EXPMA13,3),REF(EXPMA21,3)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG34:=CROSS(REF(EXPMA13,4),REF(EXPMA21,4)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG36:=CROSS(REF(EXPMA13,6),REF(EXPMA21,6)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG3:=FLAG31 OR FLAG314 OR FLAG32 OR FLAG33 OR FLAG331 OR FLAG34 OR FLAG36;

{加油买}

FLAG5:=CROSS(EXPMA13,EXPMA21) AND EXPMA13>REF(EXPMA13,1) AND EXPMA21>(EXPMA21,1) AND EXPMA55>REF(EXPMA55,1) AND EXPMA21>EXPMA55 AND REF(EXPMA55,3)>REF(EXPMA55,4) AND REF(EXPMA55,2)>REF(EXPMA55,3) AND REF(EXPMA55,1)>REF(EXPMA55,2) AND EXPMA55>REF(EXPMA55,1);

{输出标识}

DRAWTEXT(FLAG11,H,'B1'),COLORLIBLUE;

DRAWICON(FLAG11,EXPMA55,1);

DRAWTEXT(FLAG21 OR FLAG22 OR FLAG23 OR FLAG24,H,'B2'),COLORLIBLUE;

DRAWICON(FLAG21 OR FLAG22 OR FLAG23 OR FLAG24,EXPMA55,1);

DRAWTEXT(FLAG31 OR FLAG314 OR FLAG32 OR FLAG33 OR FLAG331 OR FLAG34 OR FLAG36,H,'B3'),COLORLIBLUE;

DRAWICON(FLAG31 OR FLAG314 OR FLAG32 OR FLAG33 OR FLAG331 OR FLAG34 OR FLAG36,EXPMA55,1);

DRAWTEXT(FLAG5 AND FLAG11=0 ,H,' B接力'),COLORLIBLUE;

DRAWICON(FLAG5,EXPMA55,1);

{三条均线同时转空向为转趋势}

FLAG44:=REF(EXPMA13,2)<REF(EXPMA13,1) AND EXPMA13<REF(EXPMA13,1) AND REF(EXPMA21,2)<REF(EXPMA21,1) AND EXPMA21<REF(EXPMA21,1) AND REF(EXPMA55,2)<REF(EXPMA55,1) AND EXPMA55<REF(EXPMA55,1) AND EXPMA13>EXPMA21 AND EXPMA21>EXPMA55;

DRAWICON(FLAG44,H,6);

{持股提示}

DRAWTEXT_FIX(BARSSINCEN((FLAG1 OR FLAG2 OR FLAG3 OR FLAG5),13) AND CURRBARSCOUNT=1 AND NOT(C<REF(C,1)),0.1,0.97,0,'持有提示:收盘不低于上一收盘,已入场持有!'),COLORRED;

{离场提示}

DRAWTEXT_FIX(BARSSINCEN((FLAG1 OR FLAG2 OR FLAG3 OR FLAG5),13) AND CURRBARSCOUNT=1 AND C<REF(C,1),0.1,0.97,0,'离场提示:收盘低于上一收盘价或入场已亏损5%离场!'),COLORLIGREEN;

{操作纪律}

DRAWTEXT_FIX(1=1,0.1,0.03,0,'入场:开<10%,连开<30%;持仓:亏不补;止损:损5%离'),COLORRED;

{财务情况}

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.07,0,STRCAT('市值-资产比:',STRCAT(CON2STR((FINANCE(1)*REF(C,1))/FINANCE(10) ,2),'倍(大于1表示市值大于资产)'))),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.11,0,STRCAT('股份流通比:',STRCAT(CON2STR(FINANCE(7) /FINANCE(1)*100 ,2),'%(100%为全流通)'))),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.15,0,STRCAT('每股净资产收益率(ROE):',STRCAT(CON2STR(FINANCE(33) /FINANCE(34)*100 ,2),'%'))),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.19,0,STRCAT('流动比率(CR):',STRCAT(CON2STR(FINANCE(11) /FINANCE(15) ,2),'倍(大于2流动性好)'))),COLORRED;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,0.23,0,STRCAT('上周期换手(TR):',STRCAT(CON2STR(REF(DYNAINFO(37),1)*100 ,2),'%(每日换手率在1%—2.5%)'))),COLORRED;

{盘面定性}

DRAWTEXT_FIX(NOT(REF(C,1)<REF(C,2)) AND REF(V,1)>REF(V,2) AND CURRBARSCOUNT=1,0.1,0.27,0,STRCAT('盘面:上周期放量上涨,成交量放大至',STRCAT(CON2STR(REF(V,1)/REF(V,2),2),'倍'))),COLORRED;

DRAWTEXT_FIX(NOT(REF(C,1)<REF(C,2)) AND REF(V,1)<REF(V,2) AND CURRBARSCOUNT=1,0.1,0.27,0,STRCAT('盘面:上周期缩量上涨,成交量缩小至',STRCAT(CON2STR(REF(V,1)/REF(V,2),2),'倍'))),COLORLIGREEN;

DRAWTEXT_FIX(REF(C,1)<REF(C,2) AND REF(V,1)>REF(V,2) AND CURRBARSCOUNT=1,0.1,0.27,0,STRCAT('盘面:上周期放量下跌,成交量放大至',STRCAT(CON2STR(REF(V,1)/REF(V,2),2),'倍'))),COLORLIGREEN;

DRAWTEXT_FIX(REF(C,1)<REF(C,2) AND REF(V,1)<REF(V,2) AND CURRBARSCOUNT=1,0.1,0.27,0,STRCAT('盘面:上周期缩量下跌,成交量缩小至',STRCAT(CON2STR(REF(V,1)/REF(V,2),2),'倍'))),COLORRED;

已有 0/558 人参与

发表评论:

京东购物,支持网站请点击购买!
扫描二维码

扫描二维码关注本站,了解更新资讯!