我爱环境保护

通达信五彩K指标源码汇总

发布:生态652022-3-29 12:42分类: 财经知识 标签: 意见 原创 股票池 操作 通达信

{通达信五彩K线}

{1十字星}

KSTAR:=CLOSE=OPEN AND HIGH>LOW;

{2早晨之星}

KSTAR2:=(REF(CLOSE,2)/REF(OPEN,2)<0.95) AND (REF(OPEN,1) < REF(CLOSE,2)) AND (ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03)  AND  CLOSE/OPEN>1.05  AND  CLOSE>REF(CLOSE,2);

{3黄昏之星}

KSTAR3:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);

{4长十字}

KSTAR4:=CLOSE=OPEN AND HIGH/LOW>1.03;

{5身怀六甲}

KSTAR5:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1));

{6三个白武士}

KSTAR6:=UPNDAY(CLOSE,3) AND NDAY(CLOSE,OPEN,3);

{7三只乌鸦}

KSTAR7:=DOWNNDAY(CLOSE,3) AND NDAY(OPEN,CLOSE,3);

{8光头阳线}

KSTAR8:=HIGH=CLOSE AND HIGH>LOW;

{9光脚阴线}

KSTAR9:=LOW=CLOSE AND HIGH>LOW;

{10垂死十字}

KSTAR10:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<HIGH;

{11早晨十字星}

KSTAR11:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);

{12黄昏十字星}

KSTAR12:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);

{13射击之星}

KSTAR13:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);

{14倒转锤头}

KSTAR14:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);

{1锤头}

OUT:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);

{2吊颈}

OUT2:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);

{3穿头破脚}

OUT3:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));

{4剑}

AA:=VOL>REF(VOL,1) OR VOL>(CAPITAL*0.1);

BB:=OPEN>=(REF(HIGH,1)) AND REF(HIGH,1)>(REF(HIGH,2)*1.06);

CC22:=CLOSE>(REF(CLOSE,1))-(REF(CLOSE,1)*0.01);

DD22:=CLOSE<(HIGH*0.965)  AND  HIGH>(OPEN*1.05);

EE:=LOW<OPEN  AND  LOW<CLOSE AND HIGH>(REF(CLOSE,1)*1.06);

FF:=(HIGH-(MAX(OPEN,CLOSE)))/2>(MIN(OPEN,CLOSE))-LOW;

GG:=(ABS(OPEN-CLOSE))/2<(MIN(OPEN,CLOSE)-LOW);

SWORDO:=AA AND BB AND CC22 AND DD22 AND EE AND FF AND GG;

{5出水芙蓉}

A:=CLOSE>OPEN;

B:=A AND CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,40) AND CLOSE>MA(CLOSE,60);

CC123:=B AND OPEN<MA(CLOSE,40) AND OPEN<MA(CLOSE,60);

CSFRO:=CC123 AND (CLOSE-OPEN)>0.0618*CLOSE;

{大阳烛}

DYZ:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;

{大阴烛}

DYZ1:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;

{上升三部曲}

SSSBQ:=BACKSET(

REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND

REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4), 5);

{下跌三部曲}

SDSBQ:=BACKSET(

REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND

REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,4), 5);

{乌云盖顶}

WYGD:=BACKSET(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1), 3);

{曙光初现}

SYQX:=BACKSET(REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1), 3);

{十字胎}

SZTAI:=BACKSET( ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1)), 2);

{平顶}

PINGDING:=BACKSET(ABS(HIGH-REF(HIGH,1))/HIGH<0.001,2);

{平底}

PINGDI:=BACKSET((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001),2);

{好友反攻}

HYFG:=BACKSET( (REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002),2);

{双飞乌鸦}

SFWY:=BACKSET( REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98,1);


扫描二维码

扫描二维码关注本站,了解更新资讯!