我爱环境保护

通达信MACD多重背离选股公式

发布:65环保2021-5-28 9:14分类: 财经知识 标签: 股票

{MACD}

DIFF:=MACD.DIF;

DEA:=MACD.DEA;

MACD1:=MACD.MACD;

{MACD顶底背离};

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

多重底背离:=COUNT(底背离,34);

最近成立:=BARSLAST(底背离);

{删选解禁}

非本月解禁:=NOT(INBLOCK('本月解禁'));

{删选ST、S等退市股票}

ST1:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S') OR NAMELIKE('退市') OR INBLOCK('本月解禁'));

{删选非创业板}

非创业板:=NOT(CODELIKE('30'));

{删拟减持股}

非拟减持:=NOT(INBLOCK('拟减持'));

{删除不活跃股}

非不活跃股:=NOT(INBLOCK('不活跃股'));

{删除商誉减值}

非商誉减值:=NOT(INBLOCK('商誉减值'));

{删除高管减持}

非高管减持:=NOT(INBLOCK('高管减持'));

{删除次新股}

非次新股:=NOT(INBLOCK('次新股'));

{删除近期解禁}

非近期解禁:=NOT(INBLOCK('近期解禁'));

{删除股东减持}

非股东减持:=NOT(INBLOCK('股东减持'));

{删选非科创板}

非科创板:=NOT(CODELIKE('68'));

{市值大于30亿}

市值大于30亿:=FINANCE(41)>5000000000;

{非亏损板块}

非亏损股:=NOT(INBLOCK('亏损股'));

{预计亏损股}

非预亏股:=NOT(INBLOCK('预计转亏'));

{连续亏损股}

非连续亏损股:=NOT(INBLOCK('连续亏损'));

{扣非亏损股}

扣非亏损股:=NOT(INBLOCK('扣非亏损'));

{删高商誉}

非高商誉股:=NOT(INBLOCK('高商誉'));

{删高质押股}

非高质押股:=NOT(INBLOCK('高质押股'));

{删高负债率}

非高负债率股:=NOT(INBLOCK('高负债率'));

{综合选股}

概念删除:=非本月解禁 AND 非创业板 AND 非拟减持 AND 非不活跃股 AND 非商誉减值 AND 非高管减持 AND 非次新股 AND ST1 AND 非近期解禁 AND 非股东减持 AND 非科创板 AND 非亏损股 AND 非预亏股 AND 扣非亏损股 AND 非连续亏损股 AND 非高商誉股 AND 非高质押股 AND 非高负债率股 AND 市值大于30亿;

FLAG:概念删除 AND (最近成立<3) AND (多重底背离>=2) AND (BARSCOUNT(C)>=233);


扫描二维码

扫描二维码关注本站,了解更新资讯!