我爱环境保护

通达信K线45种形态解盘-底分型、顶分型......

发布:生态652022-6-10 6:21分类: 财经知识 标签: 股票池 通达信 公式

{K线形态解盘}

TT:=240/FROMOPEN;

比:=TT;

J12:=(HIGH - ((HIGH - LOW) / 3));

J23:=(LOW + ((HIGH - LOW) / 3));

AAA:=CONST(HHV(H,90));

BBB:=CONST(LLV(L,100));

{K线形态}

T1{早晨之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));

T2{黄昏之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)> REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2)),1,0));

T3{长十字}:=CONST(IF((CLOSE=OPEN AND HIGH/LOW >1.03),1,0));

T4{垂死十字}:=CONST(IF((CLOSE=OPEN AND CLOSE=LOW AND CLOSE!=HIGH),1,0));

T5{早晨十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));

T6{黄昏十字星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2)),1,0));

T7{射击之星}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5)),1,0));

T8{倒转锤头}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5)),1,0));

T9{锤头}:=CONST(IF((HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5)),1,0));

T10{吊颈}:=CONST(IF((HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));

T11{穿头破脚}:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));

T12{乌云盖顶}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));

T13{曙光初现}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));

T14{身怀六甲}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF(OPEN,1))),1,0));

T15{十字胎}:=CONST(IF((ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND CLOSE<MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE>MIN(REF(CLOSE,1) ,REF(OPEN,1))),1,0));

T16{平顶}:=CONST(IF((ABS(HIGH-REF(HIGH,1))/HIGH<0.001),1,0));

T17{平底}:=CONST(IF(((ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1) -REF(LOW,2))/REF(LOW,1)<=0.001)),1,0));

T18{大阳烛}:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018),1,0));

T19{三个白武士}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));

T20{双飞乌鸦}:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98),1,0));

T21{孕育线}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN

AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100),1,0));

{多方炮中线版}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

T22{多方炮}:=CONST(IF(REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND REF(C,2)/REF(O,2)>1.03 AND REF(H,1)/REF(L,1)>1.03 AND REF(C,1)/REF(C,2)<1.01 AND REF(O,1)/REF(C,2)<1.01 AND C>REF(O,1) AND J<65,1,0));

T23{出水芙蓉}:=CONST(IF(((OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049)),1,0));

T24{上升三部曲}:=CONST(IF((REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2)

AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4)),1,0));

T25{下跌三部曲}:=CONST(IF(( REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND

CLOSE<REF(CLOSE,4)),1,0));

T26{跳空缺口}:=CONST(IF(HIGH<REF(LOW,1) OR LOW>REF(HIGH,1),1,0));

T27{三只乌鸦}:=CONST(IF((REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1)),1,0));

T28{光脚阴线}:=CONST(IF((LOW=CLOSE AND HIGH!=LOW),1,0));

T29{光头阳线}:=CONST(IF((HIGH=CLOSE AND HIGH!=LOW),1,0));

T30{分离}:=CONST(IF((OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0),1,0));

T31{长下影}:=CONST(IF(((MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667),1,0));

T32{长上影}:=CONST(IF(((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667),1,0));

T33{十字星}:=CONST(IF((CLOSE=OPEN AND HIGH!=LOW),1,0));

T34{大阴烛}:=CONST(IF((OPEN/CLOSE>1.05 AND HIGH/LOW<OPEN/CLOSE+0.018),1,0));

T35{好友反攻}:=CONST(IF(((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002) OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)),1,0));

T36{倾盆大雨}:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1)),1,0));

T37{放量增量}:=CONST(V*比>REF(V,1) AND MA(V,5)>REF(MA(V,5),1));

T38{缩量增量}:=CONST(V*比<REF(V,1) AND MA(V,5)>REF(MA(V,5),1));

T39{放量减量}:=CONST(V*比>REF(V,1)AND MA(V,5)<REF(MA(V,5),1));

T40{缩量减量}:=CONST(V*比<REF(V,1)AND MA(V,5)<REF(MA(V,5),1));

T41{M13}:=CONST((((IF((CLOSE=OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0))>1));

T42{均价大于高价}:=CONST((((AMOUNT / VOL) / 100) > REF(HIGH,1)));

T43{均价小于低价}:=CONST((((AMOUNT / VOL) / 100) < REF(LOW,1)));

T44{底分型}:= (COUNT((HIGH<REF(HIGH,1) AND LOW<REF(LOW,1)),3)>=1 AND LLVBARS(LOW,3) = 1 AND (HIGH>REF(HIGH,1) AND LOW>REF(LOW,1))) OR (COUNT((HIGH<REF(HIGH,1) AND LOW<REF(LOW,1)),4)>=1 AND LLVBARS(LOW,4) = 2 AND (REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1))) OR (COUNT((HIGH<REF(HIGH,1) AND LOW<REF(LOW,1)),4)>=1 AND COUNT( (HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)) OR  (HIGH>REF(HIGH,1) AND LOW<REF(LOW,1)),4)=1 AND LLVBARS(LOW,4) = 1 AND (HIGH>REF(HIGH,1) AND LOW>REF(LOW,1))) OR (COUNT((HIGH<REF(HIGH,1) AND LOW<REF(LOW,1)),5)>=1 AND COUNT((HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)) OR (HIGH>REF(HIGH,1) AND LOW<REF(LOW,1)),5)=2 AND LLVBARS(LOW,5) = 2 AND  (REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1)));

T45{顶分型}:=(COUNT((HIGH>REF(HIGH,1) AND LOW>REF(LOW,1)),4)>=2 AND HHVBARS(HIGH,4) = 1 AND  (HIGH<REF(HIGH,1) AND LOW<REF(LOW,1))) OR (COUNT((HIGH>REF(HIGH,1) AND LOW>REF(LOW,1)),5)>=2 AND HHVBARS(HIGH,5) = 2 AND (REF(HIGH,2) > HIGH AND REF(LOW,2) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1)))OR (COUNT((HIGH>REF(HIGH,1) AND LOW>REF(LOW,1)),5)>=2 AND HHVBARS(HIGH,5) = 1 AND (HIGH<REF(HIGH,1) AND LOW<REF(LOW,1))) OR (COUNT((HIGH>REF(HIGH,1) AND LOW>REF(LOW,1)),6)>=2 AND HHVBARS(HIGH,6) = 2 AND  (REF(HIGH,2) > HIGH AND REF(LOW,2) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1)));

{盘面标识}

DRAWTEXT_FIX(1=1 AND ISLASTBAR=1,0.10,0.02,0,'当期盘面'),COLORRED;

DRAWTEXT_FIX(T1=1 AND ISLASTBAR=1,0.99,0.02,1,'早晨之星:见底回升'),COLORRED ;

DRAWTEXT_FIX(T2=1 AND ISLASTBAR=1,0.99,0.08,1,'黄昏之星:见顶回落'),COLORLIGREEN ;

DRAWTEXT_FIX(T3=1 AND ISLASTBAR=1,0.99,0.14,1,'长十字:原趋势停顿'),COLORLIGREEN ;

DRAWTEXT_FIX(T4=1 AND ISLASTBAR=1,0.99,0.20,1,'垂死十字:下跌信号'),COLORLIGREEN ;

DRAWTEXT_FIX(T5=1 AND ISLASTBAR=1,0.99,0.26,1,'晨十字星:见底回升'),COLORRED ;

DRAWTEXT_FIX(T6=1 AND ISLASTBAR=1,0.99,0.32,1,'昏十字星:停顿反转'),COLORLIGREEN ;

DRAWTEXT_FIX(T7=1 AND ISLASTBAR=1,0.99,0.38,1,'射击之星:可靠性低'),COLORLIGREEN ;

DRAWTEXT_FIX(T8=1 AND ISLASTBAR=1,0.99,0.44,1,'倒转锤头:看涨信号'),COLORRED ;

DRAWTEXT_FIX(T9=1 AND ISLASTBAR=1,0.99,0.50,1,'锤头:见底回升量配合'),COLORLIGREEN ;

DRAWTEXT_FIX(T10=1 AND ISLASTBAR=1,0.99,0.56,1,'吊颈:上升见顶信号'),COLORLIGREEN ;

DRAWTEXT_FIX(T11=1 AND ISLASTBAR=1,0.99,0.62,1,'穿头破脚:见顶回落'),COLORLIGREEN ;

DRAWTEXT_FIX(T12=1 AND ISLASTBAR=1,0.99,0.68,1,'乌云盖顶:见顶回落'),COLORLIGREEN ;

DRAWTEXT_FIX(T13=1 AND ISLASTBAR=1,0.99,0.74,1,'曙光初现:见底回升'),COLORRED ;

DRAWTEXT_FIX(T14=1  AND ISLASTBAR=1,0.50,0.02,1,'身怀六甲:底升顶落'),COLORLIGREEN ;

DRAWTEXT_FIX(T15=1  AND ISLASTBAR=1,0.50,0.08,1,'十字胎:看跌或看涨'),COLOR9F5F9F ;

DRAWTEXT_FIX(T16=1  AND ISLASTBAR=1,0.50,0.14,1,'平顶:行情见顶反转'),COLORLIGREEN ;

DRAWTEXT_FIX(T17=1  AND ISLASTBAR=1,0.50,0.20,1,'平底:行情见底反转'),COLORRED ;

DRAWTEXT_FIX(T18=1  AND ISLASTBAR=1,0.50,0.26,1,'大阳烛:攀升跌反弹'),COLOR9F5F9F ;

DRAWTEXT_FIX(T19=1  AND ISLASTBAR=1,0.50,0.32,1,'三个白武士:底回升'),COLORRED ;

DRAWTEXT_FIX(T20=1  AND ISLASTBAR=1,0.50,0.38,1,'双飞乌鸦:见顶回落'),COLOR9F5F9F ;

DRAWTEXT_FIX(T21=1  AND ISLASTBAR=1,0.50,0.54,1,'孕育线:注意价位置'),COLOR9F5F9F ;

DRAWTEXT_FIX(T22=1  AND ISLASTBAR=1,0.50,0.66,1,'多方炮:底上涨中继'),COLORRED ;

DRAWTEXT_FIX(T23=1  AND ISLASTBAR=1,0.50,0.74,1,'出水芙蓉:攻势初现'),COLORRED ;

DRAWTEXT_FIX(T24=1  AND ISLASTBAR=1,0.50,0.82,1,'上升三部曲:涨信号'),COLORRED ;

DRAWTEXT_FIX(T25=1  AND ISLASTBAR=1,0.50,0.90,1,'下跌三部曲:跌信号'),COLORLIGREEN ;

DRAWTEXT_FIX(T26=1  AND ISLASTBAR=1,0.50,0.98,1,'跳空缺口:突破盘整'),COLORRED ;

DRAWTEXT_FIX(T27=1  AND ISLASTBAR=1,0.20,0.10,1,'三只乌鸦:强烈看空'),COLORLIGREEN ;

DRAWTEXT_FIX(T44=1 AND ISLASTBAR=1,0.50,0.02,1,'注意底分型'),COLORRED ;

DRAWTEXT_FIX(T45=1 AND ISLASTBAR=1,0.50,0.02,1,'注意顶分型'),COLORLIGREEN ;


扫描二维码

扫描二维码关注本站,了解更新资讯!