我爱环境保护

通达信-江恩角度线公式源码

发布:生态652022-9-6 2:36分类: 财经知识 标签: 股票池 股票 仓位控制 通达信 公式

2022-09-06_103342.png

{江恩角度工源码}

周期:=(PERIOD=0 OR PERIOD=1 OR  PERIOD=2  OR  PERIOD=3);

上角度:=70;

下角度:=70;

调点:=3;

角度:=100;

CURR:=CURRBARSCOUNT;

{M:1-1000,233}

TCH:=CONST(FINDHIGH(H,0,M,1));

GTT:=CONST(BARSLAST(TCH=H))+1;

SX跌H:=CONST(IF(GTT=1,H,REF(H,GTT-1)));

BCL:=CONST(FINDLOW(L,0,M,1));

DTT:=CONST(BARSLAST(BCL=L))+1;

SX涨L:=CONST(IF(DTT=1,L,REF(L,DTT-1)));

涨点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=SX涨L)+1));

跌点:=BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=SX跌H)+1));

最低:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,涨点,跌点)));

L斜率:=下角度/IF(C<300,1000,10);

最高:=IF(调点=1,跌点,IF(调点=2,涨点,IF(调点=3,跌点,涨点)));

H斜率:=上角度/IF(C<300,1000,10);

天线:=SX跌H;

地线:=SX涨L;

K:=(天线-地线)/(IF(跌点>=涨点,跌点,涨点)-IF(跌点>=涨点,涨点,跌点));

上斜线:=IF(地线+CONST(L斜率*4.00)*最低>=地线,地线+CONST(L斜率*4.00)*最低,DRAWNULL);

上斜线0:=IF(地线+CONST(L斜率*2.00)*最低>=地线,地线+CONST(L斜率*2.00)*最低,DRAWNULL);

上斜线1:=IF(地线+CONST(L斜率*1.5)*最低>=地线,地线+CONST(L斜率*1.5)*最低,DRAWNULL);

上斜线2:=IF(地线+CONST(L斜率*1.00)*最低>=地线,地线+CONST(L斜率*1.000)*最低,DRAWNULL);

上斜线3:=IF(地线+CONST(L斜率*0.70)*最低>=地线,地线+CONST(L斜率*0.70)*最低,DRAWNULL);

上斜线4:=IF(地线+CONST(L斜率*0.50)*最低>=地线,地线+CONST(L斜率*0.50)*最低,DRAWNULL);

上斜线5:=IF(地线+CONST(L斜率*0.365)*最低>=地线,地线+CONST(L斜率*0.365)*最低,DRAWNULL);

上斜线6:=IF(地线+CONST(L斜率*0.250)*最低>=地线,地线+CONST(L斜率*0.250)*最低,DRAWNULL);

上斜线7:=IF(地线+CONST(L斜率*0.165)*最低>=地线,地线+CONST(L斜率*0.165)*最低,DRAWNULL);

上斜线8:=IF(地线+CONST(L斜率*0.123)*最低>=地线,地线+CONST(L斜率*0.123)*最低,DRAWNULL);

上斜线9:=IF(地线+CONST(L斜率*0.06)*最低>=地线,地线+CONST(L斜率*0.06)*最低,DRAWNULL);

NOTEXT上9:IF(上斜线9<=天线*1.05 AND NOT(周期),上斜线9,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上8:IF(上斜线8<=天线*1.05 AND NOT(周期),上斜线8,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上7:IF(上斜线7<=天线*1.05 AND NOT(周期),上斜线7,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上6:IF(上斜线6<=天线*1.05 AND NOT(周期),上斜线6,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上5:IF(上斜线5<=天线*1.05 AND NOT(周期),上斜线5,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上4:IF(上斜线4<=天线*1.05 AND NOT(周期),上斜线4,DRAWNULL),COLOR0000FF,COLORYELLOW;

NOTEXT上3:IF(上斜线3<=天线*1.05 AND NOT(周期),上斜线3,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上2:IF(上斜线2<=天线*1.05 AND NOT(周期),上斜线2,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上1:IF(上斜线1<=天线*1.05 AND NOT(周期),上斜线1,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上0:IF(上斜线0<=天线*1.05 AND NOT(周期),上斜线0,DRAWNULL),COLORAA00AA,COLORRED;

NOTEXT上:IF(上斜线<=天线*1.05 AND NOT(周期),上斜线,DRAWNULL),COLORAA00AA,COLORRED;

下斜线:=IF(天线-CONST(H斜率*4.00)*最高<=天线,天线-CONST(H斜率*4.00)*最高,DRAWNULL);

下斜线0:=IF(天线-CONST(H斜率*2.00)*最高<=天线,天线-CONST(H斜率*2.00)*最高,DRAWNULL);

下斜线1:=IF(天线-CONST(H斜率*1.500)*最高<=天线,天线-CONST(H斜率*1.500)*最高,DRAWNULL);

下斜线2:=IF(天线-CONST(H斜率*1.000)*最高<=天线,天线-CONST(H斜率*1.000)*最高,DRAWNULL);

下斜线3:=IF(天线-CONST(H斜率*0.70)*最高<=天线,天线-CONST(H斜率*0.70)*最高,DRAWNULL);

下斜线4:=IF(天线-CONST(H斜率*0.50)*最高<=天线,天线-CONST(H斜率*0.50)*最高,DRAWNULL);

下斜线5:=IF(天线-CONST(H斜率*0.365)*最高<=天线,天线-CONST(H斜率*0.365)*最高,DRAWNULL);

下斜线6:=IF(天线-CONST(H斜率*0.250)*最高<=天线,天线-CONST(H斜率*0.250)*最高,DRAWNULL);

下斜线7:=IF(天线-CONST(H斜率*0.165)*最高<=天线,天线-CONST(H斜率*0.165)*最高,DRAWNULL);

下斜线8:=IF(天线-CONST(H斜率*0.123)*最高<=天线,天线-CONST(H斜率*0.123)*最高,DRAWNULL);

下斜线9:=IF(天线-CONST(H斜率*0.06)*最高<=天线,天线-CONST(H斜率*0.06)*最高,DRAWNULL);

NOTEXT下9:IF(下斜线9>=地线*0.95 AND NOT(周期),下斜线9,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下8:IF(下斜线8>=地线*0.95 AND NOT(周期),下斜线8,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下7:IF(下斜线7>=地线*0.95 AND NOT(周期),下斜线7,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下6:IF(下斜线6>=地线*0.95 AND NOT(周期),下斜线6,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下5:IF(下斜线5>=地线*0.95 AND NOT(周期),下斜线5,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下4:IF(下斜线4>=地线*0.95 AND NOT(周期),下斜线4,DRAWNULL),COLOR0000FF,COLORYELLOW;

NOTEXT下3:IF(下斜线3>=地线*0.95 AND NOT(周期),下斜线3,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下2:IF(下斜线2>=地线*0.95 AND NOT(周期),下斜线2,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下1:IF(下斜线1>=地线*0.95 AND NOT(周期),下斜线1,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下0:IF(下斜线0>=地线*0.95 AND NOT(周期),下斜线0,DRAWNULL),COLORAAAAAA,COLORGREEN;

NOTEXT下:IF(下斜线>=地线*0.95 AND NOT(周期),下斜线,DRAWNULL),COLORAAAAAA,COLORGREEN;

扫描二维码

扫描二维码关注本站,了解更新资讯!