我爱环境保护
  • 首页
  • 财经知识
  • 通达信-13\21\55日均线金叉选股公式(去除解禁、高管减持、ST等因素)

通达信-13\21\55日均线金叉选股公式(去除解禁、高管减持、ST等因素)

发布:环境技术2019-7-26 13:31分类: 财经知识 标签: 意见 原创 股票池 操作 佳奕交易系统

{指标均线}

EXPMA13:=EXPMA(C,13),COLORLIGREEN,LINETHICK1;

EXPMA21:=EXPMA(C,21),COLORLIGREEN,LINETHICK1;

EXPMA55:=EXPMA(C,55),COLORLIGREEN,LINETHICK1;

{至少完成34周期调整后上穿才有效}

{FLAG6:=REF(EXPMA13,13)<REF(EXPMA55,13) AND REF(EXPMA13,21)<REF(EXPMA55,21);}

{一日穿}

FLAG11:=CROSS(EXPMA13,EXPMA21) AND CROSS(EXPMA13,EXPMA55) AND CROSS(EXPMA21,EXPMA55);

{二日穿}

FLAG21:=CROSS(REF(EXPMA13,1),REF(EXPMA21,1)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG22:=CROSS(REF(EXPMA13,1),REF(EXPMA21,1)) AND CROSS(EXPMA13,EXPMA55) AND CROSS(EXPMA21,EXPMA55);

FLAG23:=CROSS(REF(EXPMA13,2),REF(EXPMA21,2)) AND CROSS(EXPMA13,EXPMA55) AND CROSS(EXPMA21,EXPMA55);

FLAG24:=CROSS(REF(EXPMA13,2),REF(EXPMA21,2)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

{三日穿}

FLAG31:=CROSS(REF(EXPMA13,2),REF(EXPMA21,2)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG314:=CROSS(REF(EXPMA13,4),REF(EXPMA21,4)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG32:=CROSS(REF(EXPMA13,4),REF(EXPMA21,4)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG33:=CROSS(REF(EXPMA13,3),REF(EXPMA21,3)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG331:=CROSS(REF(EXPMA13,3),REF(EXPMA21,3)) AND CROSS(REF(EXPMA13,1),REF(EXPMA55,1)) AND CROSS(EXPMA21,EXPMA55);

FLAG34:=CROSS(REF(EXPMA13,4),REF(EXPMA21,4)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

FLAG36:=CROSS(REF(EXPMA13,6),REF(EXPMA21,6)) AND CROSS(REF(EXPMA13,2),REF(EXPMA55,2)) AND CROSS(EXPMA21,EXPMA55);

{加油买}

FLAG5:=CROSS(EXPMA13,EXPMA21) AND EXPMA13>REF(EXPMA13,1) AND EXPMA21>(EXPMA21,1) AND EXPMA55>REF(EXPMA55,1) AND EXPMA21>EXPMA55 AND REF(EXPMA55,3)>REF(EXPMA55,4) AND REF(EXPMA55,2)>REF(EXPMA55,3) AND REF(EXPMA55,1)>REF(EXPMA55,2) AND EXPMA55>REF(EXPMA55,1);

{删选解禁}

本月解禁:=INBLOCK('本月解禁');

非本月解禁:=NOT(INBLOCK('本月解禁'));

{删选ST、S等退市股票}

ST1:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S') OR NAMELIKE('退市') OR INBLOCK('本月解禁'));

{删选非创业板}

非创业板:=NOT(CODELIKE('30'));

{删拟减持股}

非拟减持1:=NOT(INBLOCK('拟减持'));

{删除不活跃股}

非不活跃股:=NOT(INBLOCK('不活跃股'));

{删除商誉减值}

非商誉减值:=NOT(INBLOCK('商誉减值'));

{删除高管减持}

非高管减持:=NOT(INBLOCK('高管减持'));

{删除次新股}

非次新股:=NOT(INBLOCK('次新股'));

{周、月均线多头}

周多头1:=EXPMAS.EXPMA13#WEEK>EXPMAS.EXPMA21#WEEK AND EXPMAS.EXPMA13#WEEK>REF(EXPMAS.EXPMA13#WEEK,1) AND EXPMAS.EXPMA21#WEEK>REF(EXPMAS.EXPMA21#WEEK,1) AND EXPMAS.EXPMA55#WEEK>REF(EXPMAS.EXPMA55#WEEK,1);

周多头2:=EXPMAS.EXPMA21#WEEK>EXPMAS.EXPMA55#WEEK;

周多头:=周多头1 AND 周多头2;

月多头1:=EXPMAS.EXPMA13#MONTH>EXPMAS.EXPMA21#MONTH AND EXPMAS.EXPMA13#MONTH>REF(EXPMAS.EXPMA13#MONTH,1) AND EXPMAS.EXPMA21#MONTH>REF(EXPMAS.EXPMA21#MONTH,1) AND EXPMAS.EXPMA55#MONTH>REF(EXPMAS.EXPMA55#MONTH,1);

月多头2:=EXPMAS.EXPMA21#MONTH>EXPMAS.EXPMA55#MONTH;

月多头:=月多头1 AND 月多头2;

{选股标识}

FLAG1:=FLAG11;

FLAG2:=FLAG21 OR FLAG22 OR FLAG23 OR FLAG24;

FLAG3:=FLAG31 OR FLAG314 OR FLAG32 OR FLAG33 OR FLAG331 OR FLAG34 OR FLAG36;

FLAG4:=非本月解禁 AND 非创业板 AND 非拟减持1 AND 非不活跃股 AND 非商誉减值 AND 非高管减持 AND 非次新股 AND ST1;

FLAG:(FLAG1 OR FLAG2 OR FLAG3) AND FLAG4 AND 周多头 AND 月多头;

本选股公式原自于佳奕交易系统的源码公式

本文最后更新于2019-7-26,已超过 1 年请注意内容时效!
扫描二维码

扫描二维码关注本站,了解更新资讯!